summaryrefslogtreecommitdiff
path: root/src/librefetch/librefetch.8.ronn
diff options
context:
space:
mode:
Diffstat (limited to 'src/librefetch/librefetch.8.ronn')
-rw-r--r--src/librefetch/librefetch.8.ronn28
1 files changed, 21 insertions, 7 deletions
diff --git a/src/librefetch/librefetch.8.ronn b/src/librefetch/librefetch.8.ronn
index 895d063..6ee3ce8 100644
--- a/src/librefetch/librefetch.8.ronn
+++ b/src/librefetch/librefetch.8.ronn
@@ -4,7 +4,7 @@ librefetch(8) -- downloads or creates a liberated source tarball
## SYNOPSIS
`librefetch` [<OPTIONS>] <SOURCE-URL> [<OUTPUT-FILE>]<br>
-`librefetch` `-`[`g`|`P`|`h`]
+`librefetch` `-`[`g`|`S`|`M`|`h`]
## DESCRIPTION
@@ -12,9 +12,9 @@ librefetch(8) -- downloads or creates a liberated source tarball
tarballs for `PKGBUILD(5)` files.
If a URL mentioned in the <source> array in a `PKGUILD` is in a
-location that Parabola uploads "custom" source tarballs (or configured
-locations), and no file is at that URL, librefetch will automatically
-create it for you.
+location that Parabola uploads "custom" source tarballs to (or
+configured locations), and no file is at that URL, librefetch will
+automatically create it for you.
This works because a post-install script for the package configures
`librefetch` as the download agent for `https://` URLs in
@@ -31,7 +31,8 @@ There are 5 modes:
* `download`: Download the tarball from the configured mirror.
* `create`: Create the tarball from a `PKGBUILD`/`SRCBUILD`.
* `checksums`: Generate integrity checks for source files.
- * `print`: Print the effective build script.
+ * `srcbuild`: Print the effective build script.
+ * `makepkg`: Print the effective makepkg script.
* `help`: Print `librefetch` usage information.
The normal mode of operation is `download` mode. If `download` mode
@@ -46,9 +47,15 @@ fails, it may choose to try `create` mode.
directory, it is used instead.
* `-g` | `--geninteg`: Use `checksums` mode: Generate integrity
checks for source files.
- * `-P` | `--print`: Use `print` mode: print the effective build script.
+ * `-S` | `--srcbuild`: Use `srcbuild` mode: print the effective build
+ script.
+ * `-M` | `--makepkg`: Use `makepkg` mode: print the effective makepkg
+ script.
* `-h` | `--help`: Use `help` mode: Show useage information.
+Other options, if they are documented in `makepkg -h`, are passed to
+the modified copy of makepkg created during `create` mode.
+
## DOWNLOAD MODE
If <SOURCE-URL> begins with the string `libre://`, it is replaced with
@@ -93,7 +100,7 @@ remain intact.
As explained in the `CREATE MODE` section, in `create` mode, this
program generates an `SRCBUILD` file. For debugging purposes, this
-file can be printed instead of executed with `print` mode.
+file can be printed instead of executed with `srcbuild` mode.
### PRE-EXISTING SRCBUILD
@@ -174,10 +181,17 @@ The following modifications are made to makepkg:
* Timestamps in <$pkgdir> are reset to "1990-01-01 0:0:0 +0", so that
the resulting tarball will be the same, regardless of when it was
created.
+ * Sort the files included in the tarball; normally the order of files
+ in a tarball is essentially random (even if it tends to be the same
+ when re-created on the same machine).
* append `-libre` to <$srcdir>
* append `-libre` to <$pkgbasedir> (which becomes <$pkgdir>)
* Don't check if the package has already been built.
+For debugging purposes, this modified makepkg can be printed instead
+of executed with `makepkg` mode. Before it is run in create mode,
+`PKGEXT`, `PKGDEST`, and `pkg_file` are set as environment variables.
+
## CONFIGURATION
See `librefetch.conf(5)` for details on configuring librefetch using