summaryrefslogtreecommitdiff
path: root/src/librefetch/librefetch
diff options
context:
space:
mode:
Diffstat (limited to 'src/librefetch/librefetch')
-rwxr-xr-xsrc/librefetch/librefetch6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/librefetch/librefetch b/src/librefetch/librefetch
index 8225fc6..e3897c7 100755
--- a/src/librefetch/librefetch
+++ b/src/librefetch/librefetch
@@ -74,7 +74,7 @@ usage() {
}
main() {
- BUILDFILE="$(readlink -m PKGBUILD)"
+ BUILDFILE="$(realpath -Lm PKGBUILD)"
makepkg_opts=()
extra_opts=()
mode=download-create
@@ -143,7 +143,7 @@ main() {
# that $MIRRORS is configured.
# Canonicalize $dst
- dst="$(readlink -m -- "$dst")"
+ dst="$(realpath -Lm -- "$dst")"
# Mode: download #######################################################
@@ -236,7 +236,7 @@ parse_options() {
-g|--geninteg) mode=checksums;;
-S|--srcbuild) mode=srcbuild;;
-M|--makepkg) mode=makepkg;;
- -p) BUILDFILE="$(readlink -m -- "$optarg")";;
+ -p) BUILDFILE="$(realpath -Lm -- "$optarg")";;
-h|--help) mode=help;;
--) break;;
*)