summaryrefslogtreecommitdiff
path: root/src/librerepkg
diff options
context:
space:
mode:
Diffstat (limited to 'src/librerepkg')
-rwxr-xr-xsrc/librerepkg69
1 files changed, 69 insertions, 0 deletions
diff --git a/src/librerepkg b/src/librerepkg
new file mode 100755
index 0000000..85c58d9
--- /dev/null
+++ b/src/librerepkg
@@ -0,0 +1,69 @@
+#!/bin/bash
+# Copyright 2011 Joshua Ismael Haase Hernandez
+
+# ---------- GNU General Public License 3 ----------
+
+# This file is part of Parabola.
+
+# Parabola is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# Parabola is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
+
+. /etc/libretools.conf
+. /etc/makepkg.conf
+. /etc/abs.conf
+
+cmd=${0##*/}
+
+usage() {
+ echo "cd to a dir with a rePKGBUILD and other file info and run"
+ echo "$cmd [makepkg flags]"
+ echo ""
+ echo "This script will repackage an arch package without compiling"
+}
+
+main() {
+ while getopts 'h' arg; do
+ case $arg in
+ h) usage; exit 0 ;;
+ esac
+ done
+ makepkgflags=("$@")
+
+ if [[ ! -r rePKGBUILD ]]; then
+ error "This build does not contains a rePKGBUILD."
+ exit 1
+ fi
+ . rePKGBUILD
+
+ tempdir="$(mktemp --tmpdir -d ${PWD##*/}.XXXXX)"
+
+ msg "Copying files"
+ cp ./* "${tempdir}/"
+
+ for _arch in "${arch[@]}"; do
+ msg "Repackaging: $pkgname $pkgver-$pkgrel ($(date -u))"
+ stdnull pushd "${tempdir}"
+
+ msg2 "Updating md5sums"
+ makepkg -gp rePKGBUILD >> rePKGBUILD
+
+ echo "export CARCH=${_arch}" >> rePKGBUILD
+
+ msg "Repackaging using makepkg"
+ makepkg -Lcdp rePKGBUILD "${makepkgflags[@]}"
+
+ stdnull popd "${tempdir}"
+ done
+}
+
+main "$@"