summaryrefslogtreecommitdiff
path: root/src/libretools.conf
diff options
context:
space:
mode:
Diffstat (limited to 'src/libretools.conf')
-rw-r--r--src/libretools.conf72
1 files changed, 72 insertions, 0 deletions
diff --git a/src/libretools.conf b/src/libretools.conf
new file mode 100644
index 0000000..cde9939
--- /dev/null
+++ b/src/libretools.conf
@@ -0,0 +1,72 @@
+#!/hint/bash
+
+################################################################################
+# misc #
+################################################################################
+
+# The dir where you work on
+WORKDIR="$LIBREHOME/packages"
+
+## Blacklist URL
+BLACKLIST=https://projects.parabola.nu/blacklist.git/plain/blacklist.txt
+
+## Diff tool (vimdiff, gvimdiff, meld, etc)
+## Used by `aur`, `diff-unfree`
+DIFFPROG=$(which $([ -z "${DISPLAY:-}" ]||echo kdiff3 meld gvimdiff) vimdiff colordiff diff 2>/dev/null|sed 's/\s.*//;1q')
+
+## The architectures you'll be packaging for
+## Used by `librestage`, `xbs-abslibre`
+ARCHES=('x86_64' 'i686')
+
+## ABSLibre
+# Used by xbs-abslibre
+ABSLIBRERECV=git://projects.parabola.nu/abslibre/abslibre.git
+ABSLIBRESEND=ssh://git@projects.parabola.nu/srv/git/abslibre/abslibre.git
+ABSLIBREDEST="$WORKDIR/staging/abslibre"
+
+################################################################################
+# librerelease #
+################################################################################
+
+## Where to upload packages to
+# '/staging/' is appended; this is for compatibility with previous versions.
+REPODEST=repo@parabola.nu:staging/$LIBREUSER
+
+## These are run before and after uploading packages
+HOOKPRERELEASE="ssh -fN ${REPODEST%%:*}"
+HOOKPOSTRELEASE="sudo librechroot clean-repo"
+
+################################################################################
+# dagpkg
+################################################################################
+
+# Note: Not being set is valid for any of the HOOK* settings.
+
+# Run a command before running FULLBUILDCMD
+HOOKPREBUILD=""
+
+## Uncomment one of those or make one of your choice
+# Normal
+FULLBUILDCMD="sudo libremakepkg"
+# Cross compiling
+#FULLBUILDCMD="sudo libremakepkg -n cross-compile-chroot"
+# Don't use a chroot
+#FULLBUILDCMD="makepkg -sL --noconfirm"
+
+# Locally release the package or any other action after running FULLBUILDCMD
+# successfully. When run, it is given a repository name as a single argument.
+HOOKLOCALRELEASE="librestage"
+
+################################################################################
+# toru #
+################################################################################
+
+TORUPATH=/var/lib/libretools/toru
+
+## The repos you'll be packaging for
+## Used by: `toru-path`
+# Tip: As early repos take precedence on $REPOS loops, you can use this as
+# inverted order of precedence. Put testing repos first so dagpkg will find new
+# PKGBUILDs first, for instance. `toru-path` uses reverse order to enforce repo
+# precedence on the path cache (the last path added replaces the rest)
+REPOS=('core' 'libre' 'extra' 'community' 'libre-testing' 'social' 'sugar' 'pcr' 'java')