summaryrefslogtreecommitdiff
path: root/src/pkgbuild-check-licenses
diff options
context:
space:
mode:
Diffstat (limited to 'src/pkgbuild-check-licenses')
-rwxr-xr-xsrc/pkgbuild-check-licenses8
1 files changed, 1 insertions, 7 deletions
diff --git a/src/pkgbuild-check-licenses b/src/pkgbuild-check-licenses
index 846a6e4..c6c8132 100755
--- a/src/pkgbuild-check-licenses
+++ b/src/pkgbuild-check-licenses
@@ -24,19 +24,13 @@
. libremessages
-# Unset any PKGBUILD variables inherited from the environment
-# I took these from makepkg 4.1.1-1
-unset pkgname pkgbase pkgver pkgrel epoch pkgdesc url license groups provides
-unset md5sums replaces depends conflicts backup source install changelog build
-unset makedepends optdepends options noextract
-
# Usage: check_deps $pkgbuild
# Check whether a PKGBUILD package depends on non-free packages
check_licenses() (
# Note that we use () instead of {} for this function; so that variables
# from the PKBUILD don't bubble up
local pkgbuild=$1
- . "$pkgbuild"
+ load_PKGBUILD "$pkgbuild"
if [[ -z $pkgname ]]; then
return $_E_ERROR # not a PKGBUILD
fi