summaryrefslogtreecommitdiff
path: root/src/pkgbuild-check-nonfree
diff options
context:
space:
mode:
Diffstat (limited to 'src/pkgbuild-check-nonfree')
-rwxr-xr-xsrc/pkgbuild-check-nonfree27
1 files changed, 13 insertions, 14 deletions
diff --git a/src/pkgbuild-check-nonfree b/src/pkgbuild-check-nonfree
index b371540..7c8ca9f 100755
--- a/src/pkgbuild-check-nonfree
+++ b/src/pkgbuild-check-nonfree
@@ -70,21 +70,20 @@ check_deps() (
return $ret
)
-cmd=${0##*/}
usage() {
- echo "Usage: $cmd [OPTIONS] [PKGBUILD1 PKGBUILD2 ...]"
- echo ''
- echo "If no PKGBUILD is specified, \`./PKGBUILD' is implied"
- echo ''
- echo "Exit status:"
- echo " 0: Everything OK, no freedom issues"
- echo " 1: Ran with error"
- echo " 15: Depends on non-free packages"
- echo ''
- echo "Options:"
- echo ' -c Use the cached blacklist, do not try downloading.'
- echo ' -f Allow running as root user'
- echo ' -h Show this message'
+ print "Usage: %s [OPTIONS] [PKGBUILD1 PKGBUILD2 ...]" "${0##*/}"
+ echo
+ prose 'If no PKGBUILD is specified, `./PKGBUILD` is implied.'
+ echo
+ print "Exit status:"
+ print " 0: Everything OK, no freedom issues"
+ print " 1: Ran with error"
+ print " 15: Depends on non-free packages"
+ echo
+ print "Options:"
+ flag '-c' 'Use the cached blacklist, do not try downloading.'
+ flag '-f' 'Allow running as root user'
+ flag '-h' 'Show this message'
}
main() {