summaryrefslogtreecommitdiff
path: root/src/pkgbuild-check-nonfree
diff options
context:
space:
mode:
Diffstat (limited to 'src/pkgbuild-check-nonfree')
-rwxr-xr-xsrc/pkgbuild-check-nonfree5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/pkgbuild-check-nonfree b/src/pkgbuild-check-nonfree
index fba4b7b..0fd480c 100755
--- a/src/pkgbuild-check-nonfree
+++ b/src/pkgbuild-check-nonfree
@@ -146,12 +146,15 @@ usage() {
echo "If no PKGBUILD is specified, \`./PKGBUILD' is implied"
echo ""
echo "Options:"
+ echo " -f Allow running as root user"
echo " -h Show this message"
}
main() {
+ local asroot=false
while getopts 'fh' arg; do
case "$arg" in
+ f) asroot=true;;
h) usage; exit 0;;
*) usage; exit 1;;
esac
@@ -162,7 +165,7 @@ main() {
pkgbuilds=("`pwd`/PKGBUILD")
fi
- if [[ -w / ]]; then
+ if [[ -w / ]] && ! $asroot; then
error "Run as normal user"
exit 1
fi