summaryrefslogtreecommitdiff
path: root/src/toru/toru-path
diff options
context:
space:
mode:
Diffstat (limited to 'src/toru/toru-path')
-rwxr-xr-xsrc/toru/toru-path4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/toru/toru-path b/src/toru/toru-path
index 3f35dbe..ca87e48 100755
--- a/src/toru/toru-path
+++ b/src/toru/toru-path
@@ -32,7 +32,7 @@ msg "Updating path cache"
msg2 "${#pkgbuilds[@]} PKGBUILDs to update"
for _pkgbuild in ${pkgbuilds[@]}; do
# plain "$_pkgbuild"
- source ${_pkgbuild} >/dev/null 2>&1 || {
+ load_PKGBUILD "${_pkgbuild}" >/dev/null 2>&1 || {
error "${_pkgbuild} contains errors, skipping"
continue
}
@@ -43,8 +43,6 @@ for _pkgbuild in ${pkgbuilds[@]}; do
$VERBOSE && msg2 "${_pkg} -> ${fullpath}"
tcamgr put ${PATHFILE} ${_pkg/[<>=]*} ${fullpath}
done
-
- unset pkgbase pkgname provides
done
lastsync ${LASTSYNCFILE}