summaryrefslogtreecommitdiff
path: root/src/toru/toru-path
diff options
context:
space:
mode:
Diffstat (limited to 'src/toru/toru-path')
-rwxr-xr-xsrc/toru/toru-path9
1 files changed, 4 insertions, 5 deletions
diff --git a/src/toru/toru-path b/src/toru/toru-path
index 2c00bc7..56bea42 100755
--- a/src/toru/toru-path
+++ b/src/toru/toru-path
@@ -3,7 +3,7 @@
# Copyright (C) 2011-2012 Nicolás Reynolds <fauno@parabola.nu>
# Copyright (C) 2012 Michał Masłowski <mtjm@mtjm.eu>
# Copyright (C) 2012 Joshua Ismael Haase Hernández (xihh) <hahj87@gmail.com>
-# Copyright (C) 2014 Luke Shumaker <lukeshu@sbcglobal.net>
+# Copyright (C) 2014-2015, 2017 Luke Shumaker <lukeshu@sbcglobal.net>
#
# License: GNU GPLv3+
#
@@ -55,9 +55,8 @@ fullrepos=()
for (( i = ${#REPOS[@]}-1 ; i >= 0 ; i-- )); do
$VERBOSE && msg "Processing [%s]" "${REPOS[$i]}"
- # ABSROOT has trailing slash
- if [ -d "${ABSROOT}${REPOS[$i]}" ]; then
- fullrepos+=("${ABSROOT}${REPOS[$i]}")
+ if [ -d "${ABSROOT}/${REPOS[$i]}" ]; then
+ fullrepos+=("${ABSROOT}/${REPOS[$i]}")
fi
done
@@ -74,7 +73,7 @@ pkgbuilds=($(find "${find_args[@]}"))
# Add information from each of the PKGBUILDs to the toru cache.
msg "Updating path cache"
msg2 "%d PKGBUILDs to update" ${#pkgbuilds[@]}
-for pkgbuild in "${pkgbuilds[@]}"; do
+for _pkgbuild in "${pkgbuilds[@]}"; do
# plain "$_pkgbuild"
if ! load_PKGBUILD "${_pkgbuild}" >/dev/null 2>&1; then
error "%q contains errors, skipping" "${_pkgbuild}"