summaryrefslogtreecommitdiff
path: root/src/toru/toru-path
diff options
context:
space:
mode:
Diffstat (limited to 'src/toru/toru-path')
-rwxr-xr-xsrc/toru/toru-path30
1 files changed, 14 insertions, 16 deletions
diff --git a/src/toru/toru-path b/src/toru/toru-path
index 0d3fc70..92a4566 100755
--- a/src/toru/toru-path
+++ b/src/toru/toru-path
@@ -30,27 +30,25 @@ usage() {
print 'Create/update the `$TORUPATH/paths.tch` database.'
echo
prose 'The file `%s` is a Tokyo Cabinet database a mapping between paths
- to PKGBUILD files and `pkgname`s and `pkgbase`s. PKGBUILD files
- are scanned for in `$ABSROOT` in each of `$REPOS`.' \
- '$TORUPATH/paths.tch'
+ to PKGBUILD files and `pkgname`s and `pkgbase`s. PKGBUILD files are
+ scanned for in `$ABSROOT` in each of `$REPOS`.' '$TORUPATH/paths.tch'
echo
prose 'Additionally, it creates a timestamp file at `%s`, so that skip
PKGBUILD files that have not changed since the previous
- invocation.' \
- '$TORUPATH/lastsync.paths'
+ invocation.' '$TORUPATH/lastsync.paths'
echo
- print 'Configuration:'
- flag \
- 'libretools.conf : TORUPATH' 'Where to store `paths.tch`' \
- 'libretools.conf : REPOS' 'Which repositories to consider from `$ABSROOT`' \
- 'abs.conf : ABSROOT' 'Where to find PKGBUILD files'
+ flag 'Configuration:' \
+ 'libretools.conf::TORUPATH' 'Where to store `paths.tch`' \
+ 'libretools.conf::REPOS' 'Which repositories to consider from `$ABSROOT`' \
+ 'abs.conf::ABSROOT' 'Where to find PKGBUILD files'
echo
- print 'Options:'
- flag \
- 'T=$TORUPATH' 'Override libretools.conf:TORUPATH' \
- 'V=true' 'Be verbose' \
- 'F=true' 'Ignore timestamps; force re-scan all PKGBUILDs' \
- '-h' 'Show this message'
+ flag 'Environment:' \
+ 'T=$TORUPATH' 'Override libretools.conf:TORUPATH' \
+ 'V=true' 'Be verbose' \
+ 'F=true' 'Ignore timestamps; force re-scan all PKGBUILDs'
+ echo
+ flag 'Options:' \
+ '-h' 'Show this message'
}
main() {