summaryrefslogtreecommitdiff
path: root/src/toru/toru-utils
diff options
context:
space:
mode:
Diffstat (limited to 'src/toru/toru-utils')
-rwxr-xr-xsrc/toru/toru-utils50
1 files changed, 25 insertions, 25 deletions
diff --git a/src/toru/toru-utils b/src/toru/toru-utils
index 6ba02be..bedaf79 100755
--- a/src/toru/toru-utils
+++ b/src/toru/toru-utils
@@ -30,49 +30,49 @@ DEBUG=false
# Stores the lastsync date
lastsync() {
- local lastsyncfile
+ local lastsyncfile
- lastsyncfile=$1
+ lastsyncfile=$1
- [ -e ${lastsyncfile} -a ! -w ${lastsyncfile} ] && {
- error "The sync date can't be saved. ${lastsyncfile} isn't writable."
- return 1
- }
+ [ -e ${lastsyncfile} -a ! -w ${lastsyncfile} ] && {
+ error "The sync date can't be saved. ${lastsyncfile} isn't writable."
+ return 1
+ }
- date +%s > ${lastsyncfile}
- touch ${lastsyncfile}
+ date +%s > ${lastsyncfile}
+ touch ${lastsyncfile}
}
get_dbs() {
- local _db
- for _db in /var/lib/pacman/sync/*.db; do
- bsdtar tf ${_db} | cut -d'/' -f1 | sort -u
- done
+ local _db
+ for _db in /var/lib/pacman/sync/*.db; do
+ bsdtar tf ${_db} | cut -d'/' -f1 | sort -u
+ done
}
# repo paths
get_pkgbuilds() {
- pkgbuilds=()
+ pkgbuilds=()
- if [[ $FORCE = true || ! -e ${LASTSYNCFILE} ]]; then
+ if [[ $FORCE = true || ! -e ${LASTSYNCFILE} ]]; then
- $QUIET || warning "Forcing upgrade"
-# Get all PKGBUILDs
- extra=""
- else
-# Only find newer than lastsyncfile and read everything else from cache
- extra=" -newer ${LASTSYNCFILE}"
- fi
+ $QUIET || warning "Forcing upgrade"
+ # Get all PKGBUILDs
+ extra=""
+ else
+ # Only find newer than lastsyncfile and read everything else from cache
+ extra=" -newer ${LASTSYNCFILE}"
+ fi
-# Return all PKGBUILDs found
- find $@ -mindepth 2 -maxdepth 3 -type f -name 'PKGBUILD' ${extra}
+ # Return all PKGBUILDs found
+ find $@ -mindepth 2 -maxdepth 3 -type f -name 'PKGBUILD' ${extra}
}
# End inmediately but print a useful message
trap_exit() {
- error "$@"
+ error "$@"
- exit 1
+ exit 1
}
# Trap signals from makepkg