summaryrefslogtreecommitdiff
path: root/src/toru/toru-where
diff options
context:
space:
mode:
Diffstat (limited to 'src/toru/toru-where')
-rwxr-xr-xsrc/toru/toru-where25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/toru/toru-where b/src/toru/toru-where
new file mode 100755
index 0000000..f6df15f
--- /dev/null
+++ b/src/toru/toru-where
@@ -0,0 +1,25 @@
+#!/usr/bin/env bash
+# Locates a PKGBUILD dir on toru's path cache
+
+# Copyright (C) 2012 Nicolás Reynolds <fauno@parabola.nu>
+#
+# License: GNU GPLv3+
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+. "$(librelib conf.sh)"
+load_files libretools
+check_vars libretools TORUPATH || exit 1
+
+tcamgr get "${TORUPATH}/paths.tch" "$1" 2>/dev/null || echo ""