summaryrefslogtreecommitdiff
path: root/src/toru
diff options
context:
space:
mode:
Diffstat (limited to 'src/toru')
-rwxr-xr-xsrc/toru/toru20
-rwxr-xr-xsrc/toru/toru-info5
-rwxr-xr-xsrc/toru/toru-path4
-rwxr-xr-xsrc/toru/toru-utils5
-rwxr-xr-xsrc/toru/toru-where5
5 files changed, 38 insertions, 1 deletions
diff --git a/src/toru/toru b/src/toru/toru
index 3c45efd..16ec4af 100755
--- a/src/toru/toru
+++ b/src/toru/toru
@@ -1,6 +1,24 @@
#!/usr/bin/env bash
# Queries the ABS
-# License: GPL3
+
+# Copyright (C) 2011-2012 Nicolás Reynolds <fauno@parabola.nu>
+# Copyright (C) 2011 Joshua Ismael Haase Hernández (xihh) <hahj87@gmail.com>
+# Copyright (C) 2012-2013 Michał Masłowski <mtjm@mtjm.eu>
+# Copyright (C) 2013 Luke Shumaker <lukeshu@sbcglobal.net>
+#
+# License: GNU GPLv3
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; version 3 of the License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
## TODO
# * Add license text
diff --git a/src/toru/toru-info b/src/toru/toru-info
index d73d2ad..aa84fcf 100755
--- a/src/toru/toru-info
+++ b/src/toru/toru-info
@@ -1,5 +1,10 @@
#!/usr/bin/env bash
# Prints info about a given pkgname
+
+# Copyright (C) 2012 Nicolás Reynolds <fauno@parabola.nu>
+#
+# License: Unspecified
+
. libremessages
. $(librelib conf)
diff --git a/src/toru/toru-path b/src/toru/toru-path
index 6c86e88..407059b 100755
--- a/src/toru/toru-path
+++ b/src/toru/toru-path
@@ -1,5 +1,9 @@
#!/usr/bin/env bash
+# Copyright (C) 2011-2012 Nicolás Reynolds <fauno@parabola.nu>
+#
+# License: Unspecified
+
source toru-utils
TORUPATH=${T:-${TORUPATH}}
diff --git a/src/toru/toru-utils b/src/toru/toru-utils
index 96aa35e..2fecfc2 100755
--- a/src/toru/toru-utils
+++ b/src/toru/toru-utils
@@ -1,5 +1,10 @@
#!/usr/bin/env bash
+# Copyright (C) 2011-2012 Nicolás Reynolds <fauno@parabola.nu>
+# Copyright (C) 2012 Joshua Ismael Haase Hernández (xihh) <hahj87@gmail.com>
+#
+# License: Unspecified
+
. libremessages
. $(librelib conf.sh)
load_files libretools
diff --git a/src/toru/toru-where b/src/toru/toru-where
index 4b3ff1b..9d90972 100755
--- a/src/toru/toru-where
+++ b/src/toru/toru-where
@@ -1,5 +1,10 @@
#!/usr/bin/env bash
# Locates a PKGBUILD dir on toru's path cache
+
+# Copyright (C) 2012 Nicolás Reynolds <fauno@parabola.nu>
+#
+# License: Unspecified
+
. $(librelib conf.sh)
load_files libretools
check_vars libretools TORUPATH || exit 1