summaryrefslogtreecommitdiff
path: root/src/xbs-abs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/xbs-abs/Makefile')
-rw-r--r--src/xbs-abs/Makefile33
1 files changed, 0 insertions, 33 deletions
diff --git a/src/xbs-abs/Makefile b/src/xbs-abs/Makefile
deleted file mode 100644
index 907b3d0..0000000
--- a/src/xbs-abs/Makefile
+++ /dev/null
@@ -1,33 +0,0 @@
-include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
-include $(topsrcdir)/build-aux/Makefile.head.mk
-
-libretools.pkg = xbs
-pkgconfdir = $(sysconfdir)/xbs
-pkglibexecdir = $(libexecdir)/xbs
-
-_helpers = archrelease commitpkg
-
-libretools.pots += $(_helpers)
-libretools.src.devtools += $(addsuffix .in,$(_helpers)) valid-tags.sh
-
-libretools.out.bins =
-libretools.out.libexecs = helper-abs
-libretools.out.libs = valid-tags.sh
-
-files.out.xbs += $(_helpers)
-files.sys.xbs += $(addprefix $(pkglibexecdir)/helper-abs.d/,$(_helpers))
-
-$(outdir)/commitpkg: $(srcdir)/commitpkg.in
- @echo "OUT $@"
- @{ \
- echo '#!/usr/bin/env bash'; \
- echo '. "$$(librelib common)"'; \
- echo '. ./PKGBUILD'; \
- echo 'repo=$$1; arch=$$2;'; \
- sed -n "/== 'any'/,\$$p" $<; \
- } | install -Dm755 /dev/stdin $@
-
-$(DESTDIR)$(pkglibexecdir)/helper-abs.d/%: $(srcdir)/%
- install -Dm755 '$<' '$@'
-
-include $(topsrcdir)/build-aux/Makefile.tail.mk