summaryrefslogtreecommitdiff
path: root/src/xbs-abs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/xbs-abs/Makefile')
-rw-r--r--src/xbs-abs/Makefile26
1 files changed, 15 insertions, 11 deletions
diff --git a/src/xbs-abs/Makefile b/src/xbs-abs/Makefile
index 8688ed7..81e1b4f 100644
--- a/src/xbs-abs/Makefile
+++ b/src/xbs-abs/Makefile
@@ -1,23 +1,27 @@
+include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
+include $(topsrcdir)/automake.head.mk
pkgconfdir = $(sysconfdir)/xbs
pkglibexecdir = $(libexecdir)/xbs
-libexecs = helper-abs
_helpers = archrelease commitpkg
-no-progs = $(libexecs) $(_helpers)
-copy_files = $(addsuffix .in,$(_helpers))
-install_files = $(addprefix $(DESTDIR)$(pkglibexecdir)/helper-abs.d/,$(_helpers))
-pots = $(_helpers)
+install-bins =
+install-libexecs = helper-abs
+pots += $(_helpers)
+devtools-files += $(addsuffix .in,$(_helpers))
+am_out_files += $(_helpers)
+am_sys_files += $(addprefix $(pkglibexecdir)/helper-abs.d/,$(_helpers))
-include ../../common.mk
-
-commitpkg: commitpkg.in
- { \
+$(outdir)/commitpkg: $(srcdir)/commitpkg.in
+ @echo "OUT $@"
+ @{ \
echo '#!/usr/bin/env bash'; \
echo '. "$$(librelib common)"'; \
echo '. ./PKGBUILD'; \
echo 'repo=$$1; arch=$$2;'; \
sed -n "/== 'any'/,\$$p" $<; \
- } > $@
+ } | install -Dm755 /dev/stdin $@
-$(DESTDIR)$(pkglibexecdir)/helper-abs.d/%: %
+$(DESTDIR)$(pkglibexecdir)/helper-abs.d/%: $(srcdir)/%
install -Dm755 '$<' '$@'
+
+include $(topsrcdir)/automake.tail.mk