summaryrefslogtreecommitdiff
path: root/src/xbs-abs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/xbs-abs/Makefile')
-rw-r--r--src/xbs-abs/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/xbs-abs/Makefile b/src/xbs-abs/Makefile
new file mode 100644
index 0000000..81e1b4f
--- /dev/null
+++ b/src/xbs-abs/Makefile
@@ -0,0 +1,27 @@
+include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
+include $(topsrcdir)/automake.head.mk
+pkgconfdir = $(sysconfdir)/xbs
+pkglibexecdir = $(libexecdir)/xbs
+
+_helpers = archrelease commitpkg
+install-bins =
+install-libexecs = helper-abs
+pots += $(_helpers)
+devtools-files += $(addsuffix .in,$(_helpers))
+am_out_files += $(_helpers)
+am_sys_files += $(addprefix $(pkglibexecdir)/helper-abs.d/,$(_helpers))
+
+$(outdir)/commitpkg: $(srcdir)/commitpkg.in
+ @echo "OUT $@"
+ @{ \
+ echo '#!/usr/bin/env bash'; \
+ echo '. "$$(librelib common)"'; \
+ echo '. ./PKGBUILD'; \
+ echo 'repo=$$1; arch=$$2;'; \
+ sed -n "/== 'any'/,\$$p" $<; \
+ } | install -Dm755 /dev/stdin $@
+
+$(DESTDIR)$(pkglibexecdir)/helper-abs.d/%: $(srcdir)/%
+ install -Dm755 '$<' '$@'
+
+include $(topsrcdir)/automake.tail.mk