summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/chroot-tools/Makefile2
-rw-r--r--src/chroot-tools/hooks-chcleanup.sh7
-rw-r--r--src/chroot-tools/hooks-check.sh6
-rw-r--r--src/chroot-tools/hooks-distcc.sh4
4 files changed, 6 insertions, 13 deletions
diff --git a/src/chroot-tools/Makefile b/src/chroot-tools/Makefile
index 055b40e..c39b4f5 100644
--- a/src/chroot-tools/Makefile
+++ b/src/chroot-tools/Makefile
@@ -10,7 +10,7 @@ libretools.out.libs = $(libretools.src.sh) makechrootpkg.sh
files.out.int += chcleanup.lib
$(srcdir)/makechrootpkg.sh.in: $(srcdir)/makechrootpkg.in
- sed '/^\s*main "$$@"\s*$$/d' < $< > $@
+ sed -e '1s^.*^#!/hint/bash -euE^' -e '/^\s*main "$$@"\s*$$/d' < $< > $@
$(outdir)/chcleanup: $(srcdir)/chcleanup.in $(outdir)/chcleanup.lib
m4 -I$(@D) -P $< | $(libretools.edit) | install -m755 /dev/stdin $@
diff --git a/src/chroot-tools/hooks-chcleanup.sh b/src/chroot-tools/hooks-chcleanup.sh
index 7afb13d..e76eac0 100644
--- a/src/chroot-tools/hooks-chcleanup.sh
+++ b/src/chroot-tools/hooks-chcleanup.sh
@@ -1,5 +1,5 @@
-#!/usr/bin/env bash
-# Copyright (C) 2013 Luke Shumaker <lukeshu@sbcglobal.net>
+#!/hint/bash -euE -o pipefail
+# Copyright (C) 2013, 2017 Luke Shumaker <lukeshu@sbcglobal.net>
#
# License: GNU GPLv2+
#
@@ -16,12 +16,9 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-set -euE
-
hook_pre_build+=("clean_chroot")
clean_chroot() (
- set +x
local copydir=$1
if $INCHROOT; then
cd /startdir
diff --git a/src/chroot-tools/hooks-check.sh b/src/chroot-tools/hooks-check.sh
index 850516b..2bf3fff 100644
--- a/src/chroot-tools/hooks-check.sh
+++ b/src/chroot-tools/hooks-check.sh
@@ -1,5 +1,5 @@
-#!/usr/bin/env bash
-# Copyright (C) 2013 Luke Shumaker <lukeshu@sbcglobal.net>
+#!/hint/bash -euE -o pipefail
+# Copyright (C) 2013, 2017 Luke Shumaker <lukeshu@sbcglobal.net>
#
# License: GNU GPLv2+
#
@@ -16,8 +16,6 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-set -euE
-
hook_check_pkgbuild+=("check_pkgbuild_nonfree")
check_pkgbuild_nonfree() {
local s=0
diff --git a/src/chroot-tools/hooks-distcc.sh b/src/chroot-tools/hooks-distcc.sh
index 74edb85..2660b6d 100644
--- a/src/chroot-tools/hooks-distcc.sh
+++ b/src/chroot-tools/hooks-distcc.sh
@@ -1,4 +1,4 @@
-#!/usr/bin/env bash
+#!/hint/bash -euE -o pipefail
# Copyright (C) 2013, 2017 Luke Shumaker <lukeshu@sbcglobal.net>
#
# License: GNU GPLv2+
@@ -18,8 +18,6 @@
# You should have received a copy of the GNU General Public License
# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
-set -euE
-
hook_pre_build+=("distcc_start")
hook_post_build+=("distcc_stop")