summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/chroot-tools/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/chroot-tools/Makefile b/src/chroot-tools/Makefile
index e3274e0..412ebb5 100644
--- a/src/chroot-tools/Makefile
+++ b/src/chroot-tools/Makefile
@@ -2,12 +2,14 @@ include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
pkglibexecdir = $(libexecdir)/libretools/chroot
+pkglibdir = $(libdir)/libretools/chroot
libretools.src.devtools = makechrootpkg.in mkarchroot.in arch-nspawn.in
-libretools.out.bins = chcleanup librechroot libremakepkg
+libretools.out.bins = librechroot libremakepkg
libretools.out.libexecs = arch-nspawn chcleanup distcc-tool indent mkarchroot
libretools.out.libs = $(libretools.src.sh) makechrootpkg.sh
files.out.int += chcleanup.lib
+files.sys.all += $(bindir)/chcleanup # not in libretools.out.bins because explicit rule
$(srcdir)/makechrootpkg.sh.in: $(srcdir)/makechrootpkg.in
sed -e '1s^.*^#!/hint/bash -euE^' -e '/^\s*main "$$@"\s*$$/d' < $< > $@