summaryrefslogtreecommitdiff
path: root/test/librefetch-test.sh
diff options
context:
space:
mode:
Diffstat (limited to 'test/librefetch-test.sh')
-rw-r--r--test/librefetch-test.sh5
1 files changed, 3 insertions, 2 deletions
diff --git a/test/librefetch-test.sh b/test/librefetch-test.sh
index 13ce80f..9db836b 100644
--- a/test/librefetch-test.sh
+++ b/test/librefetch-test.sh
@@ -9,13 +9,13 @@ before() {
mkdir -p "$HOME"
printf '%s\n' \
- "DLAGENTS+=(\"libre::$(which librefetch) -p \\\"\\\$BUILDFILE\\\" %u %o\")" \
+ "DLAGENTS=({https,libre}'::$(which librefetch) -p \"\$BUILDFILE\" -- %u %o')" \
'BUILDDIR=""' \
> "$HOME/.makepkg.conf"
mkdir -p "$XDG_CONFIG_HOME/libretools"
printf '%s\n' \
- 'MIRROR="phony://example.com/dir/"' \
+ 'MIRRORS=("phony://example.com/dir/")' \
'DOWNLOADER=/usr/bin/false' \
> "$XDG_CONFIG_HOME/libretools/librefetch.conf"
}
@@ -31,6 +31,7 @@ it_displays_help() {
empty $tmpdir/stderr
}
+# This test also does a rough test of file order in the PKGBUILD
it_cleans_src_libre_first() {
cp librefetch.d/* "$tmpdir/"
cd "$tmpdir"