summaryrefslogtreecommitdiff
path: root/test/librefetch.d
diff options
context:
space:
mode:
Diffstat (limited to 'test/librefetch.d')
-rw-r--r--test/librefetch.d/PKGBUILD15
-rw-r--r--test/librefetch.d/list.txt2
2 files changed, 17 insertions, 0 deletions
diff --git a/test/librefetch.d/PKGBUILD b/test/librefetch.d/PKGBUILD
new file mode 100644
index 0000000..723d82e
--- /dev/null
+++ b/test/librefetch.d/PKGBUILD
@@ -0,0 +1,15 @@
+pkgname=testpkg
+pkgver=1.0
+pkgrel=1
+pkgdesc=foo
+arch=(any)
+source=("libre://$pkgname-$pkgver.tar.gz")
+
+mksource() {
+ mkdir "$srcdir/bar"
+ touch "$srcdir/bar/file"
+}
+
+package() {
+ :;
+}
diff --git a/test/librefetch.d/list.txt b/test/librefetch.d/list.txt
new file mode 100644
index 0000000..b04d5d1
--- /dev/null
+++ b/test/librefetch.d/list.txt
@@ -0,0 +1,2 @@
+bar/
+bar/file