summaryrefslogtreecommitdiff
path: root/test/libremakepkg-test.sh
diff options
context:
space:
mode:
Diffstat (limited to 'test/libremakepkg-test.sh')
-rw-r--r--test/libremakepkg-test.sh9
1 files changed, 6 insertions, 3 deletions
diff --git a/test/libremakepkg-test.sh b/test/libremakepkg-test.sh
index 9e54fb6..94249a9 100644
--- a/test/libremakepkg-test.sh
+++ b/test/libremakepkg-test.sh
@@ -2,19 +2,22 @@
describe libremakepkg
+. ./test-common.sh
+
before() {
- tmpdir=$(mktemp -d --tmpdir test-libremakepkg.XXXXXXXXXXXX)
+ _before libremakepkg
+
mkdir -p "$XDG_CONFIG_HOME"/libretools
echo "CHROOTDIR='$tmpdir/chrootdir'" > "$XDG_CONFIG_HOME"/libretools/chroot.conf
echo "CHROOT='default'" >> "$XDG_CONFIG_HOME"/libretools/chroot.conf
- stat=0
}
after() {
- rm -rf -- "$tmpdir" "$XDG_CONFIG_HOME"
+ _after
}
it_builds_a_trivial_package() {
+ require network sudo || return 0
cp libremakepkg.d/PKGBUILD-hello "$tmpdir/PKGBUILD"
cd "$tmpdir"