summaryrefslogtreecommitdiff
path: root/test/libremakepkg-test.sh
diff options
context:
space:
mode:
Diffstat (limited to 'test/libremakepkg-test.sh')
-rw-r--r--test/libremakepkg-test.sh5
1 files changed, 4 insertions, 1 deletions
diff --git a/test/libremakepkg-test.sh b/test/libremakepkg-test.sh
index 0cf3788..9e54fb6 100644
--- a/test/libremakepkg-test.sh
+++ b/test/libremakepkg-test.sh
@@ -6,6 +6,7 @@ before() {
tmpdir=$(mktemp -d --tmpdir test-libremakepkg.XXXXXXXXXXXX)
mkdir -p "$XDG_CONFIG_HOME"/libretools
echo "CHROOTDIR='$tmpdir/chrootdir'" > "$XDG_CONFIG_HOME"/libretools/chroot.conf
+ echo "CHROOT='default'" >> "$XDG_CONFIG_HOME"/libretools/chroot.conf
stat=0
}
@@ -17,7 +18,9 @@ it_builds_a_trivial_package() {
cp libremakepkg.d/PKGBUILD-hello "$tmpdir/PKGBUILD"
cd "$tmpdir"
- sudo -EH libremakepkg &>/dev/null
+ libremessages msg 'Creating a chroot, may take a few minutes' &>/dev/tty
+ sudo -EH libremakepkg
+
[[ -f $(echo libretools-hello-1.0-1-any.pkg.tar.?z) ]]
}