summaryrefslogtreecommitdiff
path: root/test/libremakepkg-test.sh
diff options
context:
space:
mode:
Diffstat (limited to 'test/libremakepkg-test.sh')
-rw-r--r--test/libremakepkg-test.sh18
1 files changed, 18 insertions, 0 deletions
diff --git a/test/libremakepkg-test.sh b/test/libremakepkg-test.sh
index fd86984..36176d3 100644
--- a/test/libremakepkg-test.sh
+++ b/test/libremakepkg-test.sh
@@ -163,6 +163,24 @@ it_detects_distcc_files() {
not globfile libretools-hello-1.0-1-any.pkg.tar.?z
}
+it_allows_distcc_on_long_chrootpaths() {
+ # The maximum AF_UNIX socket path is 108 bytes; so let's have
+ # a chroot name that's guaranteed to be >110 characters.
+ local chrootname=$roundup_test_name.aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
+
+ require network sudo || return 0
+ cp libremakepkg.d/PKGBUILD-distcc "$tmpdir/PKGBUILD"
+ cd "$tmpdir"
+
+ cat >> "$XDG_CONFIG_HOME/libretools/chroot.conf" <<-eot
+ CHROOTEXTRAPKG+=(distcc-nozeroconf socat)
+ eot
+ libremessages msg 'Creating a chroot, may take a few minutes' &>/dev/tty
+ testsudo librechroot -l "$chrootname" install-name distcc-nozeroconf socat
+ testsudo libremakepkg -l "$chrootname"
+ globfile libretools-distcc-1.0-1-any.pkg.tar.?z
+}
+
it_doesnt_symlink_outputs() {
require network sudo || return 0