summaryrefslogtreecommitdiff
path: root/test/libremakepkg.d/PKGBUILD-distcc
diff options
context:
space:
mode:
Diffstat (limited to 'test/libremakepkg.d/PKGBUILD-distcc')
-rw-r--r--test/libremakepkg.d/PKGBUILD-distcc23
1 files changed, 23 insertions, 0 deletions
diff --git a/test/libremakepkg.d/PKGBUILD-distcc b/test/libremakepkg.d/PKGBUILD-distcc
new file mode 100644
index 0000000..5127ae6
--- /dev/null
+++ b/test/libremakepkg.d/PKGBUILD-distcc
@@ -0,0 +1,23 @@
+pkgname='libretools-distcc'
+pkgver=1.0
+license=('GPL')
+url='https://parabola.nu'
+
+pkgrel=1
+arch=(any)
+depends=(sh)
+
+build() {
+ cd "$srcdir"
+ echo '#!/bin/sh' > hello.sh
+ echo 'echo Hello, world!' >> hello.sh
+ # I don't like hard-coding in an implementation detail, but
+ # this is the simplest way to verify that `distcc-tool
+ # odaemon` started correctly.
+ [[ -S /socket ]]
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm755 hello.sh "$pkgdir"/usr/bin/libretools-hello
+}