summaryrefslogtreecommitdiff
path: root/test/libremakepkg.d/PKGBUILD-pkgver
diff options
context:
space:
mode:
Diffstat (limited to 'test/libremakepkg.d/PKGBUILD-pkgver')
-rw-r--r--test/libremakepkg.d/PKGBUILD-pkgver23
1 files changed, 23 insertions, 0 deletions
diff --git a/test/libremakepkg.d/PKGBUILD-pkgver b/test/libremakepkg.d/PKGBUILD-pkgver
new file mode 100644
index 0000000..6b92d84
--- /dev/null
+++ b/test/libremakepkg.d/PKGBUILD-pkgver
@@ -0,0 +1,23 @@
+pkgname='libretools-pkgver'
+pkgver=1
+license=('GPL')
+url='https://parabola.nu'
+
+pkgrel=1
+arch=(any)
+depends=(sh)
+
+pkgver() {
+ echo 2
+}
+
+build() {
+ cd "$srcdir"
+ echo '#!/bin/sh' > hello.sh
+ echo 'echo Hello, world!' >> hello.sh
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm755 hello.sh "$pkgdir"/usr/bin/libretools-hello
+}