summaryrefslogtreecommitdiff
path: root/test/librestage-test.sh
diff options
context:
space:
mode:
Diffstat (limited to 'test/librestage-test.sh')
-rw-r--r--test/librestage-test.sh14
1 files changed, 14 insertions, 0 deletions
diff --git a/test/librestage-test.sh b/test/librestage-test.sh
index 11b4739..016b576 100644
--- a/test/librestage-test.sh
+++ b/test/librestage-test.sh
@@ -9,6 +9,7 @@ before() {
mkdir -p $XDG_CONFIG_HOME/libretools
echo "WORKDIR='$tmpdir/workdir'" >$XDG_CONFIG_HOME/libretools/libretools.conf
+ echo "ARCHES=('x86_64' 'i686' 'misp64el')" >>$XDG_CONFIG_HOME/libretools/libretools.conf
export HOME=$XDG_CONFIG_HOME
echo 'PKGEXT=.pkg.tar.gz' > $HOME/.makepkg.conf
@@ -69,3 +70,16 @@ it_stages_packages_to_multiple_repos() {
[[ -f $tmpdir/workdir/staging/repo2/libretools-hello-1.0-1-any.pkg.tar.gz ]]
[[ -f $tmpdir/workdir/staging/repo3/libretools-hello-1.0-1-any.pkg.tar.gz ]]
}
+
+
+it_stages_packages_without_PKGDEST() {
+ echo "PKGDEST=''" >> $HOME/.makepkg.conf
+
+ cp librestage.d/PKGBUILD-hello "$tmpdir/PKGBUILD"
+ cd "$tmpdir"
+
+ makepkg
+ librestage repo1
+
+ [[ -f $tmpdir/workdir/staging/repo1/libretools-hello-1.0-1-any.pkg.tar.gz ]]
+}