summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
Diffstat (limited to 'test')
-rw-r--r--test/librefetch-test.sh1
-rw-r--r--test/librefetch.d/PKGBUILD5
-rw-r--r--test/librefetch.d/list.txt5
3 files changed, 9 insertions, 2 deletions
diff --git a/test/librefetch-test.sh b/test/librefetch-test.sh
index 43b7a69..675299a 100644
--- a/test/librefetch-test.sh
+++ b/test/librefetch-test.sh
@@ -31,6 +31,7 @@ it_displays_help() {
empty $tmpdir/stderr
}
+# This test also does a rough test of file order in the PKGBUILD
it_cleans_src_libre_first() {
cp librefetch.d/* "$tmpdir/"
cd "$tmpdir"
diff --git a/test/librefetch.d/PKGBUILD b/test/librefetch.d/PKGBUILD
index 723d82e..db80db3 100644
--- a/test/librefetch.d/PKGBUILD
+++ b/test/librefetch.d/PKGBUILD
@@ -7,7 +7,10 @@ source=("libre://$pkgname-$pkgver.tar.gz")
mksource() {
mkdir "$srcdir/bar"
- touch "$srcdir/bar/file"
+ local file
+ for file in '~foo' '~a' a A; do
+ touch "$srcdir/bar/$file"
+ done
}
package() {
diff --git a/test/librefetch.d/list.txt b/test/librefetch.d/list.txt
index b04d5d1..9bd32f4 100644
--- a/test/librefetch.d/list.txt
+++ b/test/librefetch.d/list.txt
@@ -1,2 +1,5 @@
bar/
-bar/file
+bar/A
+bar/a
+bar/~a
+bar/~foo