summaryrefslogtreecommitdiff
path: root/toru-utils
diff options
context:
space:
mode:
Diffstat (limited to 'toru-utils')
-rwxr-xr-xtoru-utils9
1 files changed, 3 insertions, 6 deletions
diff --git a/toru-utils b/toru-utils
index bb0aef4..2488091 100755
--- a/toru-utils
+++ b/toru-utils
@@ -59,17 +59,14 @@ get_pkgbuilds() {
$QUIET || warning "Forcing upgrade"
# Get all PKGBUILDs
- pkgbuilds=($(find $@ -mindepth 2 -maxdepth 3 -type f -name 'PKGBUILD'))
-
+ extra=""
else
-
# Only find newer than lastsyncfile and read everything else from cache
- pkgbuilds=($(find $@ -mindepth 2 -maxdepth 3 -type f -name 'PKGBUILD' -newer ${LASTSYNCFILE}))
-
+ extra=" -newer ${LASTSYNCFILE}"
fi
# Return all PKGBUILDs found
- echo ${pkgbuilds[@]}
+ find $@ -mindepth 2 -maxdepth 3 -type f -name 'PKGBUILD' ${extra}
}
# End inmediately but print a useful message