summaryrefslogtreecommitdiff
path: root/toru-where
diff options
context:
space:
mode:
Diffstat (limited to 'toru-where')
-rwxr-xr-xtoru-where10
1 files changed, 3 insertions, 7 deletions
diff --git a/toru-where b/toru-where
index 02a7a88..e9ab29d 100755
--- a/toru-where
+++ b/toru-where
@@ -1,11 +1,7 @@
#!/bin/bash
# Locates a PKGBUILD dir on toru's path cache
+source /etc/libretools.conf
-source $(dirname $(command -v $0))/toru-utils
+PATHFILE=${TORUPATH}/paths.tch
-# Look in all cached but pick the last one
-grep "^${1}:" "${TORUPATH}/paths" 2>/dev/null| \
- tail -n1 2>/dev/null|\
- cut -d: -f2 2>/dev/null
-
-exit $?
+tcamgr get ${PATHFILE} $1 2>/dev/null || echo ""