summaryrefslogtreecommitdiff
path: root/treepkg
diff options
context:
space:
mode:
Diffstat (limited to 'treepkg')
-rwxr-xr-xtreepkg4
1 files changed, 4 insertions, 0 deletions
diff --git a/treepkg b/treepkg
index 00ec0e0..8a243e4 100755
--- a/treepkg
+++ b/treepkg
@@ -194,6 +194,8 @@ if [ ${DEPTH} -eq 0 ]; then
for _pkg in $(ls -r "${BUILDDIR}"); do
# Ignore if there's no PKGBUILD
if [ ! -f "${BUILDDIR}/${_pkg}/PKGBUILD" ]; then continue; fi
+# Skip if already built (faster than calling is_build again)
+ if [ -f built_ok ]; then continue; fi
${VERBOSE} && msg "Building ${_pkg/_/ }" || true
@@ -204,6 +206,8 @@ if [ ${DEPTH} -eq 0 ]; then
${FULLBUILDCMD}
# Run local release hook with $1 = $repo
${HOOKLOCALRELEASE} $(egrep ";${_pkg#*_};" "${BUILDORDER}" | cut -d';' -f6)
+
+ touch built_ok
popd >/dev/null
done