summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2017-01-18 03:31:47 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2017-01-18 03:31:47 -0500
commit06f3576fdd5aaf3450e78baf3a279a88627713c2 (patch)
tree7b18051c850bdf46a0f820fa98e04e37ff9d3d08
parent026a02b995bb0ae456c66c98f14ea0b2b761a1ea (diff)
Makefile: fix variable substitution.
Because the .go.in->.go files weren't listed in files.out, the weren't included in at.targets, so they didn't actually have the variables set when evaluated.
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 2453dbb..11b5c59 100644
--- a/Makefile
+++ b/Makefile
@@ -82,6 +82,9 @@ $(outdir)/.gopath/bin/cmd-nshd: \
$(outdir)/go/cmd-nshd/main.go: $(var)conf_file
$(outdir)/go/parabola_hackers/users.go: $(var)bindir
$(outdir)/go/parabola_hackers/passwords.go: $(var)shadow_file
+files.out.all += $(outdir)/go/cmd-nshd/main.go
+files.out.all += $(outdir)/go/parabola_hackers/users.go
+files.out.all += $(outdir)/go/parabola_hackers/passwords.go
# Go: copy out of .gopath
$(outdir)/bin/nshd: \