summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2017-01-15 01:56:50 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2017-01-15 01:56:50 -0500
commitaca833ffe2fc52c7f18b641031e371d22fd926bd (patch)
treefe5e8d06b794c4a96dbd09a03ead3bc4c160e473
parent0a1826bd8b2fe2a374112c3218b5139aba40555d (diff)
remove gnustuff
-rw-r--r--build-aux/Makefile.each.tail/11-gnustuff.mk23
-rw-r--r--build-aux/Makefile.once.head/10-gnustuff.mk56
-rw-r--r--build-aux/Makefile.once.tail/11-gnustuff.mk17
3 files changed, 0 insertions, 96 deletions
diff --git a/build-aux/Makefile.each.tail/11-gnustuff.mk b/build-aux/Makefile.each.tail/11-gnustuff.mk
deleted file mode 100644
index d89d204..0000000
--- a/build-aux/Makefile.each.tail/11-gnustuff.mk
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright (C) 2016-2017 Luke Shumaker
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU Affero General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU Affero General Public License for more details.
-#
-# You should have received a copy of the GNU Affero General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-$(foreach d,$(gnustuff.program_dirs),$(eval $(call _gnustuff.install_program,$d)))
-$(foreach d,$(gnustuff.data_dirs) ,$(eval $(call _gnustuff.install_data,$d)))
-
-$(outdir)/install-strip: install
- $(STRIP) $(filter $(addsuffix /%,$(gnustuff.program_dirs)),$(std.sys_files/$(@D)))
-
-#TAGS: TODO
-#check: TODO
-#installcheck: TODO
diff --git a/build-aux/Makefile.once.head/10-gnustuff.mk b/build-aux/Makefile.once.head/10-gnustuff.mk
deleted file mode 100644
index 759e48a..0000000
--- a/build-aux/Makefile.once.head/10-gnustuff.mk
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright (C) 2016-2017 Luke Shumaker
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU Affero General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU Affero General Public License for more details.
-#
-# You should have received a copy of the GNU Affero General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-
-mod.gnustuff.description = Misc parts of the GNU Coding Standards
-mod.gnustuff.depends += files nested
-define mod.gnustuff.doc
-# User variables:
-# - `STRIP ?= strip`
-# - `MKDIR_P ?= mkdir -p`
-# Inputs:
-# - Global variable : `gnustuff.program_dirs ?= $(bindir) $(sbindir) $(libexecdir)`
-# - Global variable : `gnustuff.data_dirs ?= <every variable from gnuconf ending in `dir`
-# that isn't bindir, sbindir, or libexecdir>
-# - Global variable : `gnustuff.dirs ?= $(gnustuff.program_dirs) $(gnustuff.data_dirs)
-# Outputs:
-# - Global variable : `nested.targets += install-strip`
-# - .PHONY target : `$(outdir)/install-strip`
-#
-# gnustuff.info_docs:
-# The list of texinfo documents in the current directory, without
-# the `.texi` suffix.
-#
-# gnustuff.program_dirs:
-# Directories to use $(INSTALL_PROGRAM) for inserting files into.
-#
-# gnustuff.data_dirs:
-# Directories to use $(INSTALL_DATA) for inserting files into.
-#
-# gnustuff.dirs:
-# Directories to create
-endef
-mod.gnustuff.doc := $(value mod.gnustuff.doc)
-
-STRIP ?= strip
-MKDIR_P ?= mkdir -p
-
-gnustuff.program_dirs ?= $(bindir) $(sbindir) $(libexecdir)
-gnustuff.data_dirs ?= \
- $(datarootdir) $(datadir) $(sysconfdir) $(sharedstatedir) $(localstatedir) $(runstatedir) \
- $(includedir) $(oldincludedir) $(docdir) $(infodir) $(htmldir) $(dvidir) $(pdfdir) $(psdir) $(libdir) $(lispdir) $(localedir) \
- $(mandir) $(man1dir) $(man2dir) $(man3dir) $(man4dir) $(man5dir) $(man6dir) $(man7dir) $(man8dir)
-gnustuff.dirs += $(gnu.program_dirs) $(gnu.data_dirs)
-
-nested.targets += install-strip
diff --git a/build-aux/Makefile.once.tail/11-gnustuff.mk b/build-aux/Makefile.once.tail/11-gnustuff.mk
deleted file mode 100644
index e4b18c0..0000000
--- a/build-aux/Makefile.once.tail/11-gnustuff.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright (C) 2016-2017 Luke Shumaker
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU Affero General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU Affero General Public License for more details.
-#
-# You should have received a copy of the GNU Affero General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-
-$(gnustuff.dirs):
- $(MKDIR_P) $@