summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-05-29 17:05:41 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-05-29 17:05:41 -0400
commit85c37c0e6f8ebf9d816f984a3499d856a2e708b1 (patch)
tree548f4673bcb1e5084efc04094114b3fd5a31e41c
parent44595e16ebcde42a730d927a0f7b563feef084a3 (diff)
tidy up
-rw-r--r--build-aux/Makefile.each.tail/10-std.mk2
-rw-r--r--build-aux/Makefile.once.head/10-std.mk12
-rw-r--r--build-aux/Makefile.once.tail/10-std.mk16
3 files changed, 10 insertions, 20 deletions
diff --git a/build-aux/Makefile.each.tail/10-std.mk b/build-aux/Makefile.each.tail/10-std.mk
index 4d36cc5..8cebc7f 100644
--- a/build-aux/Makefile.each.tail/10-std.mk
+++ b/build-aux/Makefile.each.tail/10-std.mk
@@ -38,4 +38,4 @@ _std.distclean/$(outdir) := $(filter-out
_std.maintainer-clean/$(outdir) := $(filter-out $(_std.src_files),$(_std.clean_files))
$(addprefix $(outdir)/,uninstall mostlyclean clean distclean maintainer-clean):
$(RM) -- $(sort $(_std.$(@F)/$(@D)))
- $(RMDIRS) $(sort $(dir $(_std.$(@F)/$(@D)))) 2>/dev/null || $(TRUE)
+ $(RMDIR_P) $(sort $(dir $(_std.$(@F)/$(@D)))) 2>/dev/null || $(TRUE)
diff --git a/build-aux/Makefile.once.head/10-std.mk b/build-aux/Makefile.once.head/10-std.mk
index b3d7c4a..3e058ec 100644
--- a/build-aux/Makefile.once.head/10-std.mk
+++ b/build-aux/Makefile.once.head/10-std.mk
@@ -15,9 +15,7 @@
# Declare the default target
all: build
-.PHONY: all
-
-DESTDIR ?=
+.PHONY: all noop
# Standard creative PHONY targets
at.phony += build install installdirs
@@ -31,3 +29,11 @@ at.dirlocal += std.out_files
at.dirlocal += std.sys_files
at.dirlocal += std.clean_files
at.dirlocal += std.slow_files
+
+# User configuration
+
+DESTDIR ?=
+
+RM ?= rm -f
+RMDIR_P ?= rmdir -p
+TRUE ?= true
diff --git a/build-aux/Makefile.once.tail/10-std.mk b/build-aux/Makefile.once.tail/10-std.mk
deleted file mode 100644
index 56c4f2c..0000000
--- a/build-aux/Makefile.once.tail/10-std.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-# Copyright (C) 2015-2016 Luke Shumaker
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU Affero General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU Affero General Public License for more details.
-#
-# You should have received a copy of the GNU Affero General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-
-.PHONY: noop