summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2020-02-01 20:18:32 +0100
committerAndreas Grapentin <andreas@grapentin.org>2020-02-01 20:18:32 +0100
commit36c6b54cff783e54d63994f43116d26419252db8 (patch)
tree01de1881dcd65106d44b30b3a0deb2096a27afad
parentbb3d3cb473e2ab53ee29e6f12d96a0df7a4a6b71 (diff)
dropped redirects of stderr to /dev/null
-rwxr-xr-xbin/pacman-make-keyring14
1 files changed, 7 insertions, 7 deletions
diff --git a/bin/pacman-make-keyring b/bin/pacman-make-keyring
index 702ea69..6f98d2c 100755
--- a/bin/pacman-make-keyring
+++ b/bin/pacman-make-keyring
@@ -138,29 +138,29 @@ keyid=$(keyid.$(patsubst %.asc,%,$(notdir $@)))
$(outputdir)/${KEYRING_NAME}-trusted: ${users} | $(outputdir)
$(bin)/pgp-list-keyids | sed -rn 's|^trusted/\S+ (\S+)|\1:4:|p' > $@
$(cachedir)/keys/trusted/%.asc : $(cachedir)/stamp.gpg-init | $(cachedir)/keys/trusted
- ${GPG} --recv-keys ${keyid} &>/dev/null
+ ${GPG} --recv-keys ${keyid}
printf 'minimize\nquit\ny\n' | ${GPG} --command-fd 0 --edit-key ${keyid}
- printf 'y\ny\n' | ${GPG} --command-fd 0 --lsign-key ${keyid} &>/dev/null
+ printf 'y\ny\n' | ${GPG} --command-fd 0 --lsign-key ${keyid}
${GPG} --armor --no-emit-version --export ${keyid} > $@
$(cachedir)/stamp.ownertrust: $(outputdir)/${KEYRING_NAME}-trusted $(cachedir)/deps.mk
- ${GPG} --import-ownertrust < $< 2>/dev/null
+ ${GPG} --import-ownertrust < $<
touch $@
# In 'update-keys', this is the 'packager-keyids' loop
$(cachedir)/keys/secondary/%.asc: $(cachedir)/stamp.ownertrust | $(cachedir)/keys/secondary
- ${GPG} --recv-keys ${keyid} &>/dev/null
+ ${GPG} --recv-keys ${keyid}
printf 'clean\nquit\ny\n' | ${GPG} --command-fd 0 --edit-key ${keyid}
- ${GPG} --list-keys --with-colons ${keyid} 2>/dev/null | grep -q '^pub:f:' # make sure it is trusted
+ ${GPG} --list-keys --with-colons ${keyid} | grep -q '^pub:f:' # make sure it is trusted
${GPG} --armor --no-emit-version --export ${keyid} > $@
# In 'update-keys', this is the 'packager-revoked-keyids' loop
$(outputdir)/${KEYRING_NAME}-revoked: ${users} | $(outputdir)
$(bin)/pgp-list-keyids | sed -rn 's|^revoked/\S+ ||p' > $@
$(cachedir)/keys/revoked/%.asc : $(cachedir)/stamp.ownertrust | $(cachedir)/keys/revoked
- ${GPG} --recv-keys ${keyid} &>/dev/null
+ ${GPG} --recv-keys ${keyid}
printf 'clean\nquit\ny\n' | ${GPG} --command-fd 0 --edit-key ${keyid}
- ! ${GPG} --list-keys --with-colons ${keyid} 2>/dev/null | grep -q '^pub:f:' # make sure it isn't trusted
+ ! ${GPG} --list-keys --with-colons ${keyid} | grep -q '^pub:f:' # make sure it isn't trusted
${GPG} --armor --no-emit-version --export ${keyid} > $@
$(outputdir)/${KEYRING_NAME}.gpg: $(cachedir)/deps.mk | $(outputdir)