summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-05-31 00:54:10 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-05-31 00:54:10 -0400
commit00eedbd6178cd92409be08d62b395f92680858ef (patch)
treefccfc4b8f53a9ddd7f3760178184d7d44b0d548e
parent395ed7ee8b871d7cd6c8e14a67a73ee03efa18f2 (diff)
avoid prefixing things with ./
-rw-r--r--build-aux/Makefile.tail.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/build-aux/Makefile.tail.mk b/build-aux/Makefile.tail.mk
index f7d42b9..dfbad5a 100644
--- a/build-aux/Makefile.tail.mk
+++ b/build-aux/Makefile.tail.mk
@@ -17,8 +17,8 @@
include $(call _at.reverse,$(sort $(wildcard $(topsrcdir)/build-aux/Makefile.each.tail/*.mk)))
-at.subdirs := $(addprefix $(outdir)/,$(at.subdirs))
-at.depdirs := $(addprefix $(outdir)/,$(at.depdirs))
+at.subdirs := $(patsubst ./%,%,$(addprefix $(outdir)/,$(at.subdirs)))
+at.depdirs := $(patsubst ./%,%,$(addprefix $(outdir)/,$(at.depdirs)))
# Move all of the dirlocal variables to their namespaced version
$(foreach v,$(at.dirlocal),$(eval $v/$(outdir) := $$($v)))