summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2015-11-07 23:40:03 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2015-11-07 23:40:03 -0500
commit0ddb34a594c170d12c1bf67e2d60ba1ac85ca0c8 (patch)
tree3e62f59fef7adc9efb018b3a40004461dd527a4d
parent25cc9644b2d8dae449e5a75559a202acb21b49bd (diff)
relicense common.mk to wtfpl-2
-rw-r--r--Makefile2
-rw-r--r--common.mk24
2 files changed, 6 insertions, 20 deletions
diff --git a/Makefile b/Makefile
index 5d1dbb4..96e078c 100644
--- a/Makefile
+++ b/Makefile
@@ -66,6 +66,8 @@ $(topdir)/LICENSE.gpl-2.txt: $(NET)
curl https://www.gnu.org/licenses/old-licenses/gpl-2.0.txt > $@
$(topdir)/LICENSE.apache-2.0.txt: $(NET)
curl https://www.apache.org/licenses/LICENSE-2.0 > $@
+$(topdir)/LICENSE.wtfpl-2.txt: $(NET)
+ curl http://www.wtfpl.net/txt/copying/ > $@
include $(topdir)/golang.mk
diff --git a/common.mk b/common.mk
index 7fd7964..56cfc29 100644
--- a/common.mk
+++ b/common.mk
@@ -1,23 +1,7 @@
-# Copyright 2015 Luke Shumaker
-#
-# This is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2 of
-# the License, or (at your option) any later version.
-#
-# The GNU General Public License's references to "object code" and
-# "executables" are to be interpreted to also include the output of
-# any document formatting or typesetting system, including
-# intermediate and printed output.
-#
-# This software is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public
-# License along with this manual; if not, see
-# <http://www.gnu.org/licenses/>.
+# Copyright © 2015 Luke Shumaker
+# This work is free. You can redistribute it and/or modify it under the
+# terms of the Do What The Fuck You Want To Public License, Version 2,
+# as published by Sam Hocevar. See http://www.wtfpl.net/ for more details.
rel = $(patsubst $(abspath .)/%,./%,$(abspath $1))