summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-06-17 11:23:36 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-06-17 11:23:36 -0400
commit1b6ee427ea5a33d8e036f41438c1e4dbbd7be091 (patch)
treeb740e7742a713d6061c53639610bf641ce7ad4ee
parent40f96046cdfcdaeb7714fa814d7ce540c972fd51 (diff)
copyright years
-rw-r--r--Makefile2
-rw-r--r--scripts/common.rb.in2
-rwxr-xr-xscripts/meta-cat2
-rwxr-xr-xscripts/meta-check2
-rwxr-xr-xscripts/meta-normalize-stdio4
-rwxr-xr-xscripts/pacman-make-keyring3
-rwxr-xr-xscripts/pgp-list-keyids2
-rwxr-xr-xscripts/postfix-generate-virtual-map2
-rwxr-xr-xscripts/ssh-list-authorized-keys2
-rwxr-xr-xscripts/uid-map2
-rw-r--r--src/nshd/hackers_git/db_config.go2
-rw-r--r--src/nshd/hackers_git/db_group.go2
-rw-r--r--src/nshd/hackers_git/hackers.go2
-rw-r--r--src/nshd/hackers_git/hackers_parse.go2
-rw-r--r--src/nshd/main.go.in2
15 files changed, 27 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index dc0bc13..da11652 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-# Copyright 2015 Luke Shumaker <lukeshu@sbcglobal.net>.
+# Copyright 2015-2016 Luke Shumaker <lukeshu@sbcglobal.net>.
#
# This is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License as
diff --git a/scripts/common.rb.in b/scripts/common.rb.in
index c7dc261..6e02073 100644
--- a/scripts/common.rb.in
+++ b/scripts/common.rb.in
@@ -1,3 +1,5 @@
+# Copyright 2016 Luke Shumaker <lukeshu@sbcglobal.net>.
+
require 'yaml'
def cfg
diff --git a/scripts/meta-cat b/scripts/meta-cat
index e6b9edd..8fe4111 100755
--- a/scripts/meta-cat
+++ b/scripts/meta-cat
@@ -1,6 +1,8 @@
#!/usr/bin/env ruby
# Usage: meta-cat
+# Copyright 2016 Luke Shumaker <lukeshu@sbcglobal.net>.
+
load "#{File.dirname(__FILE__)}/common.rb"
print load_all_users.to_yaml
diff --git a/scripts/meta-check b/scripts/meta-check
index 4a2981e..5862c2e 100755
--- a/scripts/meta-check
+++ b/scripts/meta-check
@@ -1,4 +1,6 @@
#!/bin/bash
+# Copyright 2014, 2016 Luke Shumaker <lukeshu@sbcglobal.net>.
+# Copyright 2015 Márcio Alexandre Silva Delgado <coadde@parabola.nu>.
. libremessages
diff --git a/scripts/meta-normalize-stdio b/scripts/meta-normalize-stdio
index c55487f..42cbe6e 100755
--- a/scripts/meta-normalize-stdio
+++ b/scripts/meta-normalize-stdio
@@ -1,4 +1,8 @@
#!/usr/bin/env ruby
+# coding: utf-8
+
+# Copyright 2014, 2016 Luke Shumaker <lukeshu@sbcglobal.net>.
+# Copyright 2015 Márcio Alexandre Silva Delgado <coadde@parabola.nu>.
# First we define a bunch of code-generators, then at the end is a
# very neat and readable definition of the format of the YAML files.
diff --git a/scripts/pacman-make-keyring b/scripts/pacman-make-keyring
index 589984d..4fa2a0d 100755
--- a/scripts/pacman-make-keyring
+++ b/scripts/pacman-make-keyring
@@ -1,5 +1,8 @@
#!/usr/bin/make -rRf
# Usage: pacman-make-keyring V=$(date -u +%Y%m%d)
+
+# Copyright 2014, 2016 Luke Shumaker <lukeshu@sbcglobal.net>.
+
ifeq ($(origin V),undefined)
$(info Usage: pacman-make-keyring V=$$(date -u +%Y%m%d))
$(error You must set V= on the command line)
diff --git a/scripts/pgp-list-keyids b/scripts/pgp-list-keyids
index 9682b1a..822c89c 100755
--- a/scripts/pgp-list-keyids
+++ b/scripts/pgp-list-keyids
@@ -1,6 +1,8 @@
#!/usr/bin/env ruby
# Usage: pgp-list-keyids
+# Copyright 2014, 2016 Luke Shumaker <lukeshu@sbcglobal.net>.
+
load "#{File.dirname(__FILE__)}/common.rb"
load_all_users.each do |uid,user|
diff --git a/scripts/postfix-generate-virtual-map b/scripts/postfix-generate-virtual-map
index d5c2d21..2620060 100755
--- a/scripts/postfix-generate-virtual-map
+++ b/scripts/postfix-generate-virtual-map
@@ -1,6 +1,8 @@
#!/usr/bin/env ruby
# Usage: postfix-show-virtual-map > ${file} && postmap hash:${file}
+# Copyright 2014, 2016 Luke Shumaker <lukeshu@sbcglobal.net>.
+
load "#{File.dirname(__FILE__)}/common.rb"
users = load_all_users.values.find_all{|u|u["groups"].include?("email")}
diff --git a/scripts/ssh-list-authorized-keys b/scripts/ssh-list-authorized-keys
index 5fb1ea1..7bda72b 100755
--- a/scripts/ssh-list-authorized-keys
+++ b/scripts/ssh-list-authorized-keys
@@ -1,6 +1,8 @@
#!/usr/bin/env ruby
# Usage: ssh-list-authorized-keys [username]
+# Copyright 2014, 2016 Luke Shumaker <lukeshu@sbcglobal.net>.
+
load "#{File.dirname(__FILE__)}/common.rb"
all_users = load_all_users.values
diff --git a/scripts/uid-map b/scripts/uid-map
index 10c3fac..01665bc 100755
--- a/scripts/uid-map
+++ b/scripts/uid-map
@@ -1,6 +1,8 @@
#!/usr/bin/env ruby
# Usage: uid-map
+# Copyright 2016 Luke Shumaker <lukeshu@sbcglobal.net>.
+
load "#{File.dirname(__FILE__)}/common.rb"
load_all_users.each do |uid,user|
diff --git a/src/nshd/hackers_git/db_config.go b/src/nshd/hackers_git/db_config.go
index f049b90..5f5fea9 100644
--- a/src/nshd/hackers_git/db_config.go
+++ b/src/nshd/hackers_git/db_config.go
@@ -1,4 +1,4 @@
-// Copyright 2015 Luke Shumaker <lukeshu@sbcglobal.net>.
+// Copyright 2015-2016 Luke Shumaker <lukeshu@sbcglobal.net>.
//
// This is free software; you can redistribute it and/or
// modify it under the terms of the GNU General Public License as
diff --git a/src/nshd/hackers_git/db_group.go b/src/nshd/hackers_git/db_group.go
index 7e97c05..07c1a1f 100644
--- a/src/nshd/hackers_git/db_group.go
+++ b/src/nshd/hackers_git/db_group.go
@@ -1,4 +1,4 @@
-// Copyright 2015 Luke Shumaker <lukeshu@sbcglobal.net>.
+// Copyright 2015-2016 Luke Shumaker <lukeshu@sbcglobal.net>.
//
// This is free software; you can redistribute it and/or
// modify it under the terms of the GNU General Public License as
diff --git a/src/nshd/hackers_git/hackers.go b/src/nshd/hackers_git/hackers.go
index 90628a4..b8b9f22 100644
--- a/src/nshd/hackers_git/hackers.go
+++ b/src/nshd/hackers_git/hackers.go
@@ -1,4 +1,4 @@
-// Copyright 2015 Luke Shumaker <lukeshu@sbcglobal.net>.
+// Copyright 2015-2016 Luke Shumaker <lukeshu@sbcglobal.net>.
//
// This is free software; you can redistribute it and/or
// modify it under the terms of the GNU General Public License as
diff --git a/src/nshd/hackers_git/hackers_parse.go b/src/nshd/hackers_git/hackers_parse.go
index 9dcfcc7..e2efd16 100644
--- a/src/nshd/hackers_git/hackers_parse.go
+++ b/src/nshd/hackers_git/hackers_parse.go
@@ -1,4 +1,4 @@
-// Copyright 2015 Luke Shumaker <lukeshu@sbcglobal.net>.
+// Copyright 2015-2016 Luke Shumaker <lukeshu@sbcglobal.net>.
//
// This is free software; you can redistribute it and/or
// modify it under the terms of the GNU General Public License as
diff --git a/src/nshd/main.go.in b/src/nshd/main.go.in
index 59e032e..ae2d2b7 100644
--- a/src/nshd/main.go.in
+++ b/src/nshd/main.go.in
@@ -1,4 +1,4 @@
-// Copyright 2015 Luke Shumaker <lukeshu@sbcglobal.net>.
+// Copyright 2015-2016 Luke Shumaker <lukeshu@sbcglobal.net>.
//
// This is free software; you can redistribute it and/or
// modify it under the terms of the GNU General Public License as