summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2015-09-02 12:57:47 -0600
committerLuke Shumaker <lukeshu@sbcglobal.net>2015-09-02 12:57:47 -0600
commit5fa621f8dfe2ccd674d8d94eb148c10b52b4fca0 (patch)
tree37ef5cf831ee18d02d44bc9a7021905bf4f5e823
parentee165667d271b29eef70c9726bf6af45778cb470 (diff)
Turn on C warnings/errors
-rw-r--r--Makefile5
-rw-r--r--src/nshd/hackers_git/name2gid.go7
2 files changed, 8 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 32cf638..492bb7a 100644
--- a/Makefile
+++ b/Makefile
@@ -5,6 +5,9 @@ systemddir = $(libdir)/systemd
GOPATH := $(realpath $(dir $(lastword $(MAKEFILE_LIST))))
+CFLAGS = -std=c99 -Wall -Wextra -Werror -pedantic
+CGO_CFLAGS = $(CFLAGS) -Wno-unused-parameter
+
deps = gopkg.in/yaml.v2
subdirs = src/nslcd_proto
@@ -38,7 +41,7 @@ $(foreach d,$(deps),$(eval src/$d: NET; GOPATH='$(GOPATH)' go get -d -u $d))
.PHONY: NET
bin/nshd: $(download) $(generate) $(shell find src -name .git -prune -o -print)
- GOPATH='$(GOPATH)' go install nshd
+ GOPATH='$(GOPATH)' CGO_CFLAGS='$(CGO_CFLAGS)' go install nshd
$(DESTDIR)$(bindir)/%: bin/%
install -Dm755 $< $@
diff --git a/src/nshd/hackers_git/name2gid.go b/src/nshd/hackers_git/name2gid.go
index b33e6aa..c155d29 100644
--- a/src/nshd/hackers_git/name2gid.go
+++ b/src/nshd/hackers_git/name2gid.go
@@ -5,9 +5,10 @@ import (
"unsafe"
)
-//#include <stdlib.h> /* free */
-//#include <unistd.h> /* sysconf */
-//#include <grp.h> /* getgrnam_r */
+//#define _XOPEN_SOURCE /* for getgrnam_r(3) in grp.h */
+//#include <stdlib.h> /* for free(3) */
+//#include <unistd.h> /* for sysconf(3) */
+//#include <grp.h> /* for getgrnam_r(3) */
import "C"
func name2gid(name string) (gid int32) {