summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2019-12-10 20:13:06 -0500
committerbill-auger <mr.j.spam.me@gmail.com>2019-12-12 22:27:33 -0500
commit1acad34504f0343c736f367aa44aaf5e1ae6b32e (patch)
treef9245f0432c0145aa4b0c3e3e7a14627d4a5b530
parent21e1d186c5a2a672dd495fa2f023985a9b939504 (diff)
update README.md
-rw-r--r--README.md36
1 files changed, 32 insertions, 4 deletions
diff --git a/README.md b/README.md
index 6e766a5..00c4304 100644
--- a/README.md
+++ b/README.md
@@ -23,7 +23,7 @@ The others are:
- `pgp-list-keyids`: used by `pacman-make-keyring`
- `uid-map`: used by `pacman-make-keyring`
-Each of the programs looks for `parabola-hackers.yml` in he current
+Each of the programs looks for `parabola-hackers.yml` in the current
directory (except for `meta-normalize-stdio`, which has no
configuration).
@@ -43,14 +43,41 @@ store files that can be cached between versions of the keyring.
## ssh-list-authorized-keys
`ssh-list-authorized-keys` also looks at `ssh_pseudo_users`.
-System users (`/etc/passwd`) mentioned in this variable may be SSH'ed
-into by hackers.git users who are in a group of the same name.
+System users (`/etc/passwd`) mentioned in this variable, may be SSH'ed
+into by hackers.git users who are in a hackers.git "group" of the same name.
+Note that in this context, "group" is in quotes; because these are abstract
+capability groups as defined in `parabola-hackers.yml`, which do not
+necessarily correspond to system groups on any server.
## nshd
`nshd` also looks at `pam_password_prohibit_message` to decide what to
say when prohibiting a user from being changed via PAM.
+# Compiling
+
+Compile the tools:
+
+$ git submodule init
+$ git submodule update
+
+$ YYYYMMDD=$(date +%Y%m%d)
+$ sed "s|\(VERSION *= *\).*|\1$YYYYMMDD|" config.mk
+$ git commit -m 'prepare release' config.mk
+$ make && make check && make dist
+
+Build and publish the source-ball and package:
+
+* sign parabola-hackers-*.tar.gz with GPG
+* upload the source-ball and signature to the repo server
+ under the 'other/parabola-hackers/' directory
+* set 'pkgver' in libre/parabola-hackers/PKGBUILD
+ to the same $YYYYMMDD as config.mk above
+* ensure that 'validpgpkeys' in libre/parabola-hackers/PKGBUILD
+ is set to your GPG key,
+* build and publish the package normally with libretools
+* publish the PKGBUILD to abslibre
+
# Usage
## meta-check
@@ -77,7 +104,7 @@ or
cd $(. "$(librelib conf)" && load_files makepkg && echo "$SRCDEST")
pacman-make-keyring V=$(date -u +%Y%m%d)
-In the latter case, it would get uploaded automagically by
+In the latter case, it would get uploaded auto-magically by
`librerelease` when you release a parabola-keyring with the matching
version.
@@ -98,6 +125,7 @@ Then enable and start `nshd.socket`:
----
Copyright (C) 2014, 2016-2017 Luke Shumaker
+Copyright (C) 2019 bill-auger
This documentation file is placed into the public domain. If that is
not possible in your legal system, I grant you permission to use it in