summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-09-17 13:55:27 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2017-09-17 13:55:27 -0400
commitc4a530a64cf5128478ba912dacd07e719add5c79 (patch)
treecf82e02efb363aeb7e1f3c689ead8c9adeea32d8
parent582e545a2d82f49df606bf03235b4c2e9f6dfd81 (diff)
Makefile: use the race detector when running tests
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 4b5506e..f436ca6 100644
--- a/Makefile
+++ b/Makefile
@@ -91,7 +91,7 @@ $(outdir)/go/bin/nshd: $(outdir)/$(files.generate) $(outdir)/go/src/nshd/nshd_fi
files.out.all += $(outdir)/go/src/nshd/nshd_files/paths.go
$(outdir)/check:
- GOPATH=$$PWD/go go test $$(GOPATH=$$PWD/go go list -f '{{.ImportPath}}{{"\n"}}{{join .Deps "\n"}}' $(bins_go) | sort -u | grep -e ^nshd -e '\.[^/]*/')
+ GOPATH=$$PWD/go go test -race $$(GOPATH=$$PWD/go go list -f '{{.ImportPath}}{{"\n"}}{{join .Deps "\n"}}' $(bins_go) | sort -u | grep -e ^nshd -e '\.[^/]*/')
.PHONY: $(outdir)/check
at.targets += $(outdir)/check