summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2015-08-28 20:36:44 -0600
committerLuke Shumaker <lukeshu@sbcglobal.net>2015-08-28 20:36:44 -0600
commit4f16ef5707daf4acd74a07b665d1d67ab97c1f44 (patch)
tree4be4a4f4fd263e36eb99e20ab3086c7c7423eba6 /Makefile
parente2bebdb069b45bd8deb04536bd4772bfec3376b7 (diff)
tidy Makefiles
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 41ea59f..0ccd82e 100644
--- a/Makefile
+++ b/Makefile
@@ -6,10 +6,11 @@ systemddir = $(libdir)/systemd
GOPATH := $(realpath $(dir $(lastword $(MAKEFILE_LIST))))
deps = golang.org/x/exp/inotify gopkg.in/yaml.v2
+subdirs = src/nslcd_proto
all: build
-include src/nslcd_proto/Makefile
+include $(addsuffix /Makefile,$(subdirs))
secondary +=
download += $(addprefix src/,$(deps))
@@ -25,7 +26,7 @@ install: $(install)
clean:
rm -rf -- pkg bin src/*.*/
- rm -f -- $(generate) $(build) $(decondary)
+ rm -f -- $(generate) $(build) $(secondary)
.PHONY: clean
uninstall: