summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2015-11-08 00:54:10 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2015-11-08 00:54:10 -0500
commitd9732f58a7609d7614c80bde3ac9d682ceabf698 (patch)
treeab84dedc80f04ed45e99ce5cdbf951cecd6b95a1 /Makefile
parent0ddb34a594c170d12c1bf67e2d60ba1ac85ca0c8 (diff)
tidy Makefile
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 96e078c..7f98070 100644
--- a/Makefile
+++ b/Makefile
@@ -37,12 +37,9 @@ CGO_CFLAGS = $(CFLAGS) -Wno-unused-parameter
CGO_ENABLED = 1
deps += gopkg.in/yaml.v2
-deps += lukeshu.com/git/go/libgnulinux.git/dl
-deps += lukeshu.com/git/go/libgnulinux.git/getgr
-deps += lukeshu.com/git/go/libgnulinux.git/inotify
-deps += lukeshu.com/git/go/libnslcd.git/proto
-deps += lukeshu.com/git/go/libnslcd.git/systemd
-deps += lukeshu.com/git/go/libsystemd.git/sd_daemon
+deps += lukeshu.com/git/go/libgnulinux.git
+deps += lukeshu.com/git/go/libnslcd.git
+deps += lukeshu.com/git/go/libsystemd.git
srcdir := $(abspath $(patsubst %/,%,$(dir $(lastword $(MAKEFILE_LIST)))))
topdir := $(srcdir)
@@ -53,12 +50,13 @@ generate += $(addprefix $(topdir)/src/,$(deps))
generate += $(topdir)/LICENSE.lgpl-2.1.txt $(topdir)/LICENSE.gpl-2.txt $(topdir)/LICENSE.apache-2.0.txt
generate_secondary += $(topdir)/src/*.*/
build += $(topdir)/bin/nshd $(topdir)/nshd.service $(topdir)/nshd.socket $(topdir)/test/runner
-build_secondary += $(topdir)/test/*.o
+build_secondary += $(topdir)/bin $(topdir)/pkg $(topdir)/test/*.o .var.*
install += $(addprefix $(DESTDIR),$(bindir)/nshd $(systemddir)/system/nshd.socket $(systemddir)/system/nshd.service)
ifeq (1,$(words $(MAKEFILE_LIST)))
include $(topdir)/common.mk
endif
+src/lukeshu.com/git/go/libnslcd.git/proto/Makefile: $(topdir)/src/lukeshu.com/git/go/libnslcd.git
$(topdir)/LICENSE.lgpl-2.1.txt: $(NET)
curl https://www.gnu.org/licenses/old-licenses/lgpl-2.1.txt > $@