summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2015-08-26 20:25:52 -0600
committerLuke Shumaker <lukeshu@sbcglobal.net>2015-08-26 20:25:52 -0600
commit13bb2e14fcdd260d060b7240357d4a8a80002114 (patch)
tree8bd49d988aa597c98578833b0b82b952b203c98b /Makefile
parenta6ac8f680062069b2821214f5b74cc96673ee4ca (diff)
work
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..aa394e8
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,21 @@
+prefix = /usr/local
+bindir = $(prefix)/bin
+
+export GOPATH=$(realpath $(dir $(lastword $(MAKEFILE_LIST))))
+
+all: build
+
+generate:
+ $(MAKE) -C src/nslcd_proto
+
+build: generate
+ go install nshd
+
+clean:
+ rm -rf -- pkg bin
+ $(MAKE) -C src/nslcd_proto clean
+
+install: build
+ install -Dm755 bin/nshd $(bindir)/nshd
+
+.PHONY: all generate build clean