summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2015-10-26 15:29:27 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2015-10-26 15:29:27 -0400
commit262836f32d4f1d774a399d6a680fc75a132743ef (patch)
treeb03b8b9d968234f5233807c2d60744fbddb57a14 /Makefile
parente68a2db09c147affbad364048b03d7436ea738ed (diff)
Makefile: fix gosrc
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index a9f2e06..91dd37e 100644
--- a/Makefile
+++ b/Makefile
@@ -36,8 +36,9 @@ CGO_ENABLED = 1
export CGO_ENABLED
cgo_variables = CGO_ENABLED CGO_CFLAGS CGO_CPPFLAGS CGO_CXXFLAGS CGO_LDFLAGS CC CXX
-goext = c s S cc cpp cxx h hh hpp hxx
-gosrc = $(shell find -L src -name '.*' -prune -o \( -type f \( $(foreach e,$(goext), -name '*.$e' ) \) -o -type d \) -print)
+goext = go c s S cc cpp cxx h hh hpp hxx
+gosrc_cmd = find -L src -name '.*' -prune -o \( -type f \( -false $(foreach e,$(goext),-o -name '*.$e') \) -o -type d \) -print
+gosrc = $(shell $(gosrc_cmd))
GOPATH := $(realpath $(dir $(lastword $(MAKEFILE_LIST))))