summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2015-10-26 15:29:57 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2015-10-26 15:29:57 -0400
commitb22ddee242613929fa5ca40a6b759e175a889ed7 (patch)
tree269ae345bf4b249dd8bdf98f82bb01375554c0ae /Makefile
parent262836f32d4f1d774a399d6a680fc75a132743ef (diff)
Makefile: tidy
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 91dd37e..8630cd8 100644
--- a/Makefile
+++ b/Makefile
@@ -28,7 +28,7 @@ systemddir = $(libdir)/systemd
user = nshd
group = nshd
-NET ?= NET
+NET ?= FORCE
CFLAGS = -std=c99 -Wall -Wextra -Werror -pedantic
CGO_CFLAGS = $(CFLAGS) -Wno-unused-parameter
@@ -76,7 +76,6 @@ uninstall:
rmdir -p -- $(sort $(dir $(install))) 2>/dev/null || true
.PHONY: uninstall
-
LICENSE.lgpl-2.1.txt: $(NET)
curl https://www.gnu.org/licenses/old-licenses/lgpl-2.1.txt > $@
LICENSE.gpl-2.txt: $(NET)
@@ -113,4 +112,3 @@ $(DESTDIR)$(systemddir)/system/%.service: %.service
.SECONDARY:
.DELETE_ON_ERROR:
-.PHONY: NET