summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-06-17 22:13:51 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-06-17 22:13:51 -0400
commit05764d3a94e8643990e0c5d20b736dcfc5819b15 (patch)
treea5edbf22602fc0767c2e8cd2d4da55c243e318d4 /Makefile
parent6b3d4df8053a8dd6e53b5415c1793d553d35e883 (diff)
fix race condition in Makefile
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 43af046..79b21d6 100644
--- a/Makefile
+++ b/Makefile
@@ -67,7 +67,7 @@ $(outdir)/.gopath/src: $(golang.var)
mkdir $(@D)
ln -sr $(topsrcdir)/go $@
touch $@
-$(outdir)/.gopath/bin/cmd-nshd: $(call golang.src,$(outdir)/.gopath) $(_gen) $(_out)
+$(outdir)/.gopath/bin/cmd-nshd: $(patsubst $(outdir)/.gopath/src/%,go/%,$(call golang.src,$(outdir)/.gopath)) $(_gen) $(_out)
$(call golang.install,$(topoutdir)/.gopath,cmd-nshd)
$(outdir)/%.o: $(srcdir)/%.c $(var)CC $(var)CPPFLAGS $(var)CFLAGS