summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2015-09-18 17:45:34 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2015-09-18 17:45:34 -0400
commit3ecd3c8e3d6643986960d6266d71643df8f7c22e (patch)
treea1efd756838023645373b39bdfa34eb0ba81681b /Makefile
parentaecb837a5cf531d83aebe7666f400d56fa3ab1ed (diff)
Massive documentation and copyright clean-up.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile35
1 files changed, 32 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 031a775..997f8e8 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,24 @@
+# Copyright 2015 Luke Shumaker <lukeshu@sbcglobal.net>.
+#
+# This is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# The GNU General Public License's references to "object code" and
+# "executables" are to be interpreted to also include the output of
+# any document formatting or typesetting system, including
+# intermediate and printed output.
+#
+# This software is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public
+# License along with this manual; if not, see
+# <http://www.gnu.org/licenses/>.
+
MAKEFLAGS += --no-builtin-rules
prefix = /usr/local
bindir = $(prefix)/bin
@@ -23,7 +44,7 @@ GOPATH := $(realpath $(dir $(lastword $(MAKEFILE_LIST))))
vp = .Makefile.var.%
deps = gopkg.in/yaml.v2
-subdirs = src/nslcd_proto
+subdirs = src/nslcd/proto
all: build
@@ -31,7 +52,7 @@ include $(addsuffix /Makefile,$(subdirs))
secondary += test/*.o
download += $(addprefix src/,$(deps))
-generate +=
+generate += LICENSE.lgpl-2.1.txt LICENSE.gpl-2.txt LICENSE.apache-2.0.txt
build += bin/nshd nshd.service nshd.socket test/runner
install += $(addprefix $(DESTDIR),$(bindir)/nshd $(systemddir)/system/nshd.socket $(systemddir)/system/nshd.service)
@@ -51,8 +72,15 @@ uninstall:
rmdir -p -- $(sort $(dir $(install))) 2>/dev/null || true
.PHONY: uninstall
+
+LICENSE.lgpl-2.1.txt: $(NET)
+ curl https://www.gnu.org/licenses/old-licenses/lgpl-2.1.txt > $@
+LICENSE.gpl-2.txt: $(NET)
+ curl https://www.gnu.org/licenses/old-licenses/gpl-2.0.txt > $@
+LICENSE.apache-2.0.txt: $(NET)
+ curl https://www.apache.org/licenses/LICENSE-2.0 > $@
+
$(foreach d,$(deps),$(eval src/$d: $(NET); GOPATH='$(GOPATH)' go get -d -u $d))
-.PHONY: NET
bin/nshd: $(download) $(generate) $(gosrc) $(addprefix .Makefile.var.,$(cgo_variables))
@true $(foreach f,$(filter $(vp),$^), && test $@ -nt $f ) || rm -rf -- bin pkg
@@ -81,3 +109,4 @@ $(DESTDIR)$(systemddir)/system/%.service: %.service
.SECONDARY:
.DELETE_ON_ERROR:
+.PHONY: NET