summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2015-09-18 17:51:26 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2015-09-18 17:51:26 -0400
commitad1dec18b3fcd809e198af51344564413c6816d1 (patch)
treeecb693f4f7bcde8b0d912ec4d5725c14158598d2 /Makefile
parent89fd9bcde7a12bf9d35fe2c7829760186bb05b5e (diff)
Only clean `generate` targets on maintainer-clean
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 997f8e8..a9f2e06 100644
--- a/Makefile
+++ b/Makefile
@@ -64,8 +64,11 @@ install: $(install)
clean:
rm -rf -- pkg bin src/*.*/
- rm -f -- $(generate) $(build) $(secondary)
+ rm -f -- $(build) $(secondary)
.PHONY: clean
+maintainer-clean: clean
+ rm -f -- $(generate)
+.PHONY: maintainer-clean
uninstall:
rm -f -- $(install)