summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2012-09-05 13:41:01 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2012-09-05 13:41:01 -0300
commit0b414a9942dc8efd808438bc4f8d3a6a3ade6503 (patch)
tree3081a5e95718d4db399d0b30a438b45f135c31ef /Makefile
parente8c608c19859d5b9363eb58c46a140abb42557d1 (diff)
The Makefile
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..accda79
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,17 @@
+PREFIX=/srv/git
+USER=git
+SHELL=/usr/bin/git-shell
+HACKERS=$(PWD)
+
+# Create the user
+user:
+ useradd -d $(PREFIX) -m -r -s $(SHELL) -U
+
+install: user
+ pushd $(PREFIX)
+ git clone --bare $(HACKERS) hackers.git
+ git clone hackers.git .ssh
+ chmod 700 .ssh
+ chmod 600 .ssh/authorized_keys
+ ln -s $(PREFIX)/.ssh/git-hooks/* hackers.git/hooks/
+ ln -s $(PREFIX)/.ssh/git-shell-commands .