summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2012-09-08 19:40:49 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2012-09-08 19:40:49 -0300
commit3ce233785c903b62b7f2e7eb64a71a0ba81a33fc (patch)
tree7e992c4d43d6962794deedb5c2c94154647d399c /Makefile
parent52b532ed5228f2415ae7790e30cf29dc941b13e3 (diff)
The *Working* Makefile
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index a5cfa59..9d03294 100644
--- a/Makefile
+++ b/Makefile
@@ -7,11 +7,13 @@ HACKERS=$(PWD)
user:
useradd -d $(PREFIX) -m -r -s $(GIT_SHELL) -U $(USER)
-install: user
- pushd $(PREFIX)
- git clone --bare $(HACKERS) hackers.git
- git clone hackers.git .ssh
- chmod 700 .ssh
- chmod 600 .ssh/authorized_keys
- ln -s $(PREFIX)/.ssh/git-hooks/* hackers.git/hooks/
- ln -s $(PREFIX)/.ssh/git-shell-commands .
+# Create the hackers.git bare repo and clone as .ssh
+# Then create needed symlinks and add hooks to hackers.git
+install:
+ cd $(PREFIX); \
+ git clone --bare $(HACKERS) hackers.git && \
+ git clone hackers.git .ssh && \
+ chmod 700 .ssh && \
+ chmod 600 .ssh/authorized_keys && \
+ ln -s $(PREFIX)/.ssh/git-hooks/* hackers.git/hooks/ && \
+ ln -s $(PREFIX)/.ssh/git-shell-commands